Mantis - Cafesterol
Erweiterte Problemanzeige
17 general Absturz immer 2008-08-09 17:09 2008-08-11 13:30
raboof  
xclerc  
normal  
erledigt  
erledigt  
keine    
keine 1.0  
0000017: current darcs does not build with ocaml 3.10.2
I followed the instructions on the wiki. Everything went fine until 'make -f Makefile.cafesterol', which failed.

(this issue may be moved to Barista as needed :) )
arnouten@bird:~/dev/cafesterol/ocaml-3.10.2$ make -f Makefile.cafesterol
./ocamlc -w Ae -I utils -I parsing -I typing -I bytecomp -I asmcomp -I javacomp -I driver -I toplevel -I +zip -I +barista -c asmcomp/debuginfo.mli
./ocamlc -w Ae -I utils -I parsing -I typing -I bytecomp -I asmcomp -I javacomp -I driver -I toplevel -I +zip -I +barista -c utils/jclflags.mli
./ocamlc -w Ae -I utils -I parsing -I typing -I bytecomp -I asmcomp -I javacomp -I driver -I toplevel -I +zip -I +barista -c utils/jconfig.mli
./ocamlc -w Ae -I utils -I parsing -I typing -I bytecomp -I asmcomp -I javacomp -I driver -I toplevel -I +zip -I +barista -c utils/jcomp.mli
./ocamlc -w Ae -I utils -I parsing -I typing -I bytecomp -I asmcomp -I javacomp -I driver -I toplevel -I +zip -I +barista -c javacomp/jlambda.mli
./ocamlc -w Ae -I utils -I parsing -I typing -I bytecomp -I asmcomp -I javacomp -I driver -I toplevel -I +zip -I +barista -c javacomp/printjlambda.mli
./ocamlc -w Ae -I utils -I parsing -I typing -I bytecomp -I asmcomp -I javacomp -I driver -I toplevel -I +zip -I +barista -c javacomp/macroinstr.mli
./ocamlc -w Ae -I utils -I parsing -I typing -I bytecomp -I asmcomp -I javacomp -I driver -I toplevel -I +zip -I +barista -c javacomp/printminstr.mli
./ocamlc -w Ae -I utils -I parsing -I typing -I bytecomp -I asmcomp -I javacomp -I driver -I toplevel -I +zip -I +barista -c javacomp/bytecodeutils.mli
File "javacomp/bytecodeutils.mli", line 24, characters 40-65:
Unbound type constructor BaristaLibrary.Utils.utf8
make: *** [javacomp/bytecodeutils.cmi] Error 2
arnouten@bird:~/dev/cafesterol/ocaml-3.10.2$
Problem-Historie
2008-08-09 17:09 raboof Neues Problem
2008-08-09 20:23 raboof Problemnotiz hinzugefügt: 0000017
2008-08-10 22:47 xclerc Problemnotiz hinzugefügt: 0000020
2008-08-10 22:47 xclerc Bearbeitung durch => xclerc
2008-08-10 22:47 xclerc Status neu => anerkannt
2008-08-11 13:29 xclerc Problemnotiz bearbeitet: 0000020
2008-08-11 13:30 xclerc Problemnotiz bearbeitet: 0000020
2008-08-11 13:30 xclerc Status anerkannt => erledigt
2008-08-11 13:30 xclerc Behoben in Version => 1.0
2008-08-11 13:30 xclerc Lösung offen => erledigt

Notiz
(0000017)
raboof   
2008-08-09 20:23   
The problem was that I hadn't (correctly) installed Barista yet. I added a note to http://ocamljava.x9c.fr/wiki/doku.php?id=cafesterol [^] .

(looks like I don't have permission to update this issue, it can be set to 'resolved, invalid' or something similar)
(0000020)
xclerc   
2008-08-10 22:47   
(bearbeitet am: 2008-08-11 13:30)
This kind of error message usually arise if the user has not a working copy
of Barista installed. The user is thus advised to follow the Barista build process,
and to make sure that no error comes up, including during the "installation" phase.

To check that Barista is installed, one should check that:
  - the directory named `ocamlc -where`/barista actually exists;
  - this directory contains the ".a", ".cma", ".cmi", ".cmj", ".cmja", ".cmo", ".cmx", "cmxa", and ".jar"
  files for the "BaristaLibrary" module.