Mantis - Bolt
Erweiterte Problemanzeige
54 general kleinerer Fehler nicht getestet 2010-01-09 23:07 2010-01-10 11:02
elehack  
xclerc  
normal  
erledigt  
erledigt  
keine    
keine 1.1  
0000054: META file does not contain all dependencies
The Bolt library file imports the Unix, Str, and Dynlink modules, but the ocamlfind META file does not list these packages as dependencies. The result is that compilation lines for programs using Bolt must also include the unix, str, and dynlink packages even if the program does not directly use those facilities.

This can be fixed by a simple change to the "requires" line in the META file.
Problem-Historie
2010-01-09 23:07 elehack Neues Problem
2010-01-10 11:02 xclerc Problemnotiz hinzugefügt: 0000203
2010-01-10 11:02 xclerc Status neu => erledigt
2010-01-10 11:02 xclerc Behoben in Version => 1.1
2010-01-10 11:02 xclerc Lösung offen => erledigt
2010-01-10 11:02 xclerc Bearbeitung durch => xclerc

Notiz
(0000203)
xclerc   
2010-01-10 11:02   
Thanks for reporting; the bug is now fixed in the darcs repository.